Start a new topic

S20 can't upgrade firmware

I have 11x S20 sonoff sockets. 8 of them I have upgraded to firmware 1.6.0 from the ewelink software without a problem. 


I have 3 devices that will not upgrade


1x S20 with 1.5.2 firmware


2x S20 with 1.5.5 firmware



I've tried power cycling them, restarting the app, restarting the phone etc several times. They have failed to upgrade several times. 


It's wierd that 8 devices upgrade fine, but 3 don't so something must be different. 


How do I debug this? 


Thanks


1 person has this problem

I have come here for the same reason
min will start then fail or hang at 90% then fail

I too have tried different phone, accounts, use hot spot on phone instead of the wifi router
but all fails to come from 1.5.5 to 1.6

so i then tried to do this from the app but not connected to my wifi (i am at work) at it seems to have worked. t now has 1.6.

I will need to wait till i get home i want to reboot it and be sure.

I have many devices but only the  1 S20

 

I am facing this issue.. Ive tried with Wifi , ive tried device on wifi and phone on 4G. Ive tried device on hotspot and phone on same hotspot. and ive tried Device on hotspot and phone on 4g. 

It always fails at 90%


This definitely needs to be addressed. If there needs to be incremental updates, so be it. But it should be addressed

Same issue, never success the update even one of them
Login or Signup to post a comment