Start a new topic

Sonoff T1 and Huawei HG633 on TalkTalk (UK)

Hi all,


Has anyone managed to get their T1 light switch to connect to an HG633 router and stay connected? This TalkTalk super router (hmmmm....) seems completely unable to sustain a connection. No other device in the house has a problem, including all other devices in the same room (iPad, phones, TV, Echo etc.).


I've tried connecting it via an access point and directly to the router with same results. I had a similar problem with a printer that I fixed by assigning a fixed IP address on the printer and the router. I tried assigning a fixed IP on the router for the T1 but that doesn't seem to have helped.


The switch works fine when connected via a phone hotspot, so I'm pretty sure it's the router and its settings and not the switch itself. I'd buy more and do the whole house if I could figure out how to connect these! 


If anyone has successfully done this and can share any settings they tweaked on the router it would be much appreciated. I've turned off the 5Ghz band already BTW.


I have just purchased the Sonoff RF bridge and I am suffering the same issue. It will connect to a phone hotspot but not to the TalkTalk router. Tried changing as many setting as I dare with no success.

Probably not what you want to hear but I gave up in the end and bought a cheap tp link Archer router, by cheap I mean it was about £70 but cheap in comparison to the mimo routers and others on the market. The switch connects fine now and maintains a connection, so it's definitely the router that's the problem. You could try a cheaper router if you don't need fibre and so on, but this seemed like a reasonable cost/feature balance. Sorry I couldn't help with the HG633 settings.

Many thanks for the reply. Perhaps I need to look for another solution.

Login or Signup to post a comment