Start a new topic

Google home linking has stopped working

 Google home linking seems to have stopped working.


I added a couple of touch switches to my account, un-linked from google and tried to re-link, all I get is "linking..." then "couldn't update setting. please check your connection" error.


the connection is there. even wrong password is being identified as wrong, but the linking never happens.


I am guessing something in the back-end has gone wrong.



11 people have this problem

Facing the same issue. I tried , an older version but then realised the mobile app has nothing to do with the Google Home integration. I get a message on my mobile as it has been linked successfully , but there are no devices on the list. I think something to do with the back end integration. 


Hope it gets fixed soon. 

I have the same problem. It was working and then I tried to add some more Sonoff devices and I've un-linked the account. After that I re-linked the account and now I can't add the devices in Google home anymore?

PUBLIC HOLIDAY FROM OCT. 1th TO OCT. 9th IN WHOLE CHINA !!!!!


out of curiosity, is anybody of you all out working in your holidays?

same here "Something went wrong. Try again." starting to think about returning my devices if this is the kind of support we are getting

I'm trying to set mine up but keep getting the error message "Something went wrong. Try again."

Very frustrating to say the least as having them working would be a real bonus for my disabled wife.

Hi there, 


I've the same issue! It was working some weeks ago and then I just tried to add some more Sonoff devices and I've un-linked the account.

I’m also dealing with the same problem as you ...

Hey guys,

im having the same problem. I ordered a couple specifically to use with my google home so this is very annoying.

Since the Chinese have some kind of Holiday from 1st Oct until 8th Oct. (https://www.timeanddate.com/holidays/china/)

That pisses me off just as you, i hope they then roll back to an older version so we can still use our products..


i hope you guys understand why nothing will change for the next couple of days...

Same problem here ! is anyone looking at this major issue ?

This is a big deal. I hope they fix it soon. This is the main selling point feature of these devices!
Same here. Is Itead checking on this? Looks like who perform the unlink and link will hit into the same issue. Who ever consider to unlink to detect more device can consider to stay put as for now .

I am having the same problem every time i try to add device on my google home i get  "couldn't update setting. please check your connection"

I picked today to finally wire up my Sonoff... oops.

Attempting to add a Smart Web Link account or device in Google Home Control causes the error "Couldn't update the setting. Check your connection"

Tried unlinking my Google account from my Home and then doing a Factory Reset on it as per some threads about other IoT devices having this issue - no dice.