Start a new topic

Arduino not reciving data from Nextion

Hi guys!I've a problem with Arduino and Nextion LCD.Almost everything is ok,but,Arduino is not reciving data from Nextion in Serial.This is very important for me because ,if Arduino not recive the codes,the dual-states buttons not work.Please help !!!

Btw,sorry my english .

ino
(9.63 KB)

Describe problem effectively to get effective answers.


Which Arduino Board?  without such informations no one can assist.

Which Library used?  Iteadlib, custom, other?? Again ...


Nextion Dual state buttons DO work - this you can count on.

If Arduino does not receive the codes (is this correct??)

  - then look into WHY does Arduino not receive the codes.


In the Nextion Debug - is Nextion even sending the codes??


Iteadlib Arduino Nextion Library questions supported in this Forum

Not Iteadlib Arduino Nextion Library ... ask in Library Forum


If not receiving because serial is not configured or conflict exists

then ask in Arduino Board Forum


1 person likes this

Hi,Patrick!Yes,I'm sorry that i wasn't very explicit.And Yes,in Nextion Debug ,the simulator,Nextion sending the codes.I use Arduino Mega and the library is Nextion_master.

In Iteadlib Arduino Nextion Library ,i don't know how to modify the photo of dual states button manually.This is the code which I use Iteadlib Arduino Nextion Library,and,again ,I don't know how to make the dual states buttons to update their states when i change the state of the relay from WebServer.And yes ,Arduino does not recive the codes,but it send with the code in which I used the Iteadlib Arduino Nextion Library.I attached also the HMI File.Thanks for reply,Patrick !

HMI
ino
(6.84 KB)

In honest.  Your code looks little like usable code as written.

Much of the Iteadlib Arduino Nextion version is fitted sufficient for Nextion

 - but then other logic strays away from being usable.


When you want to learn to deal with Nextion

   write a smaller program that deals with Nextion only.

When you have that working with a dualstate

  add a little more and test that.


You have a dual-state example from the github in examples folder

Login or Signup to post a comment