Start a new topic

Nextion stopped working: only sends 0x65 0x00 0xff 0x01 0xff 0xff 0xff

I had been working OK- connected to Arduino and sending direct serial commands (no library). Then it stopped working and will only send 0x65 0x00 0xff  0x01 0xff 0xff 0xff  no matter where it's touched. This is true when directly running from Nextion Editor over serial via FTDI. 


I can send commands (change text values) OK


I reloaded the file and another completely different file via SD and via serial. Didn't help. 

I'm guessing it's misreading the touch location seeing it as invalid and returning a component ID of 0xff. 

Is there anything I can try to fix it or is it just broken? 

Thanks


0x65 0x00 0x00 0x01 0xFF 0xFF 0xFF

0x65 touch event Page 0 component 0 (page non component) Pressed.


Upload code and HMI file.

I do not think it is a touch issue

Nextion Instruction Set - touch_j

  can be used to recalibrate touch sensor.


I put the original itlead firmware on it and that would not send any serial data. I put mine back on and it worked for a few minutes then went back to
x65 0x00 0xff 0x01 0xff 0xff 0xff

(there's a typo in your reply- ID is ff not 0.)

Thanks


from where did you get your display? Can you provide me your

    - Order details as
      - Order number
      - Order date  
      - Seller data

  - Display data as
    - Display type
    - Display serial number

 

Late night misread.  0xFF 255, non-component.





Nextion NX4024K032 Touch Display Enhanced Versions 3.2 Inch HMI LCD
Order Placed: April 26, 2017
Amazon.com order number: 112-6388008-3140204

Is there anything I can do to resolve this? Thanks


Without knowing the results of what has been already asked

 - hard to know which path to suggest next

 - path may have already been mentioned

When certain is hardware issue and not software related

 - then contacting dealer, perhaps less so before known

I supplied the requested information 2 days ago. What questions are unanswered?


result of touch_j command

 - unknown if even issued

code and HMI was requested to see if cause was code based


>> result of touch_j command 

 You did not say to run this. You said "I do not think it is a touch issue" so why would i run a test to calibrate touch? Anyway I ran it and it displays the first test point but nothing happens when I touch it. The display does not change at all.


>code and HMI was requested to see if cause was code based
I said already that I uploaded the demo hmi that came came with it to eliminate any problems with that or code. With the demo hmi loaded, it displays the screen but does not respond to touch or swipes. Wth debug connected, it does not display any return data when i tap the screen. 

to make a more deep analysis, the display must be physically available, which is not the case ...

therefore, from technical side there is nothing more to tell ...

if it is a hardware issue, just contact the amazon seller for legal warranty handling ...

 

I tried loading a blank HMI- didn't help. I created an HMI with 2 large buttons- one covering the top half of the screen and the other the bottom half. Pressing repeatedly on the same area in the bottom area would occasionally activate the bottom button. Pressing many times on the top half would occasionally activate the BOTTOM (not top) button. Never got the top button to activate no matter where i touched.


Is there any deeper reset than the flashing firmware?

no ...


Referring back to the touch_j results

   with what did you touch the first spot

    - was blunt stylus for resistive displays used?

      can make difference, can cause

    - no movement to next spot, very bad sign but not only factor  


Conflicting details and/or lack of details

  - does not send any data with 0x65 sent

  - put original demo back on (this is not possible)

    - demo code already modified by newer version

    - can not load v0.37 and older once v0.38+ is loaded

  

Can not nail down from sporadic info/indirect answers.

 - code + HMI would have allowed to see if commands

   that influence such were used, can cause

 - to rule such out? or time dancing around issue?


Debug mode with Send Command to Nextion Device selected

 - allows to see Nextion's actual responses

    - is it really not sending, or not being responded to

    - broken/fractured wires, can cause

    - improper grounding and all not common, can cause

    - improper voltage, can cause a non response

 - knowing more of setup and config required to explore

   MCU used, how wired, blah-blah-blah, etc ...

    

Less sense in asking if mounted, how, what used to mount, etc

 - possible damage to cables or sensor, can cause

 - adhesive, glue used, other, when mounting, can cause

Usually try to rule out previous before arriving at this step


Order of troubleshooting

  - when this is determined or ruled out - then proceed to next.


2 1/2 months, less delivery time - did display ever work?

 - untold factors between when working and not, can cause


When the cause is known - how to fix (if possible) also known.

 - seems less likely to be told the details of what caused


But perhaps roll the dice and see what reseller will do

 - which reseller (Amazon) was asked prior by Gerry

   some resellers new Nextion, some used Nextion and refurbished Nextion

Login or Signup to post a comment