Start a new topic
Solved

Crop Number image causes screen issue

When I crop a number image it works in the debugger, but when I actually load it causes screen to mess up.  See below  I tried to attached HMI but too large.


image



From the HMI you provided

You have no component I can immediately identify 

   or Nextion side code that is placing this there.

So I am resolved that this is initiated in MCU side code.


But look closely at your picture.

  - you have a RED #3

Could certainly be an ill formatted xstr command.


Also page pic background in picture is not matching HMI

This could also be use of cropped image when crop is not full screen


"Config" in HMI design is only on page 0

Enable 16 in HMI design is only on page 1

HMI Background is photo is missing


I made it simpler. One screen only.  I have attached test.hmi and tft to this post and will attach test_crop to next post as exceeds size limit


Test.MNI  - No crop, works fine

Test_crop.HMI  - causes issue

tft
(5.04 MB)
HMI
(5.82 MB)

test_crop data

tft
(5.04 MB)
HMI
(5.82 MB)

Cropping requires there to be data from referenced image to crop from to exist.

As such your background was fine

 - but photo shows that this background is not present

   so look for MCU side code that changed this.


I don't know what you mean by "MCU side code"?

MCU side code

- code running on STM32F103 EPS8622, Arduino Mega .etc

What you connected your Nextion too 

  it is sending commands to the Nextion


Forget the picture,  the new test screens have background.  Please load them and see what I am talking about.

I have nothing attached.  Power and ground only!  Load the code!

I have told you where your error lays.

But lets be perfectly clear

 - I am no one's bitch to debug user code.


I examined both powerquest.HMI and test.HMI

The attached photo above is your evidence.


If you have more updated evidence provide it

but keep the tone much more cool

this is MY time I volunteer to your issue

I am in no means obligated to


So if we are clear on that proceed with a new photo


I have examined your latest testcrop.HMI


I have your answer when you have my apology!

"I have your answer when you have my apology!"


Sorry do not understand this comment?


Also,  I have 25 years experience in embedded systems and feel I have acted professionally with the issue I have presented to you.  I have also been doing a significant increase in business with ITEAD on both these screens and PCB orders.   I do not appreciate the term "BITCH" being used in this discussion.  Very unprofessional!

As per the Nextion FAQs (second sentence)


We offer Level 2 support to customers, please understand that we can not debug your code, we can only ensure the hardware itself works as expected.


So not very professional to jump queue for priority handling

  You open a Level 2 support Ticket to try to get preferential treatment

  You open a Bug Report as if to blame your user error on Nextion firmware

  Then you got rude and pushy:

     "I have nothing attached.  Power and ground only!  Load the code!"


How this behaviour is deemed professional escapes me

So when I volunteer my Time to debug your user error in your code

 - you don't honour this in any professional manner.


It doesn't matter how much business you do with Itead

 - that all of a sudden give you the right to abuse your helper? I think not.


And as a volunteer going above and beyond to successfully debug your code,

for which I am in no way obligated to do so, your business with Itead has nothing

to do with how you treat me. - and this you call professional?  So I will indeed

point out in no ambiguous manner where such a line has been crossed.


My duties are to ensure board order, I do not have to answer questions.

And I have devoted months of MY time to answer quickly and technically.

It has been almost a year since Anyone had to wait a day for answers.


So I do indeed expect an apology for such.



I know where your Nextion error is because I am the best there is.  Sorry.


As told in my first post above


    Also page pic background in picture is not matching HMI

    This could also be use of cropped image when crop is not full screen


As told in my second post above


    Cropping requires there to be data from referenced image to crop from to exist.


Not my duties to debug your code, and still I wasted MY time to do so.


Your error is the result of your improper use of cropping

  - from what data is Nextion to use for graphical cropping when your reference is too small?

The crop image needs to be full screen, or at least to cover the area you are cropping from.


When you have ax2_cur_num .id 4 in testcrop.HMI at position (516,430) for 50x20

  this expects to filter against your crop image 43 from 516,439 to 555,449

What do you have in picture resource #43?  a resource 50x20.

  Had ax2_cur_num been at 0,0 then from 0,0 to 49,19 would have worked.

But when such is an out of bound data, then unexpected results are expected.

(As such you read into font data, two bytes per pixel giving a funky effect)


Such results from out of bounds should be well know by experienced embedded coder.

So this was neither a Level 2 hardware issue or a Nextion firmware bug.


But as such apology has not been made,

I won't mistake to offer my volunteer time for such issues in the future again.

I had no intention of accessing level 2 support is and have not purposely asked for it. I simply started out by clicking on tech support, posting a question, and then you answered and requested that I go to bug report section.


I in no way, was looking for or expecting preferential treatment. So I am sorry if you thought I was.


I was getting frustrated as I thought you were blowing off my questions by commenting on previous post instead of looking at the changes I made to the current post to help you understand the issue I was having.


I have no idea if you work for ITEAD or are a volunteer? I logged into ITEAD website/tech support and asked a question and you answered.


I appreciate you help regardless if you are an employee of ITEAD or a volunteer.


To answer you question above  YES:  "What do you have in picture resource #43?  a resource 50x20."


If I understand you answer I need the background Image to be slightly larger?  I guess felt there may be a firmware bug as this works fine as in in the debugger.

Login or Signup to post a comment