Start a new topic

Android App Keeps Crashing In Background

Android app on android N Samsung S7 Edge keeps crashing. Can't control my three devices. Only way to fix it is to uninstall and reinstall. Then it works for a few hours till it crashes again. Restarting phone doesn't help and android keeps popping up with a "the app has crashed" and "this app is slowing down your device" messages. Android now says ewelink has caused 1200 errors in the last 7 days. Tried clearing storage, and force stop, even restarting, but all I get is a white screen. Have sent message via Feedback. For the moment I'm signing out after each use, then back in to use the app. Seems to be a problem in the app when it runs in background.

3 people have this problem

This latest version after 3 days is stable with no errors. I have restarted the phone... Remotely controlled the devices... Set timers and set temperatures. I also pressed the button on my sonoff and the app posted a notification correctly.  Hopefully be updated on Google play soon.
Only been testing it for almost a day. This is where things normally start going wrong. So far so good. To those waiting.... They are definitely working on it. Hopefully this version will be a winner. I'm waiting 4 days before I report back to the developers.
The new software 2.3.5.3 seams stable  Have been a couple of days now and no problems so far. Anyone else ho can confirm that It works?

Hi, I'd like to know if someone knows if there are another app that works with Sonoff set? Thanks

Best regards to all. 

Hi all. I can confirm the continued issue with Android 7.0 is being worked on. Hopefully we will have a good result in the following week or so.
Reinstalled new version every day since it was released.
I confirm : same problem after about 24 hours... !!!

 

Evilink chrash i my  Samsung S7 (v7) also with the new version of eWeLink (2.3.4) installed 
Has gradually reinstalled app + 20 times  :o(

Get it now kindly fixed

Definitely still crashing for me on the new version. Android says FIX NOW, but even if you don't press it the app still crashes and is just a white screen again. Takes about 24 hours to fail. I did report this issue to them about the newer version but it seems they released it anyway.

New version of eWeLink (2.3.4) installed this morning... Launched about 10 times : for the moment, no problem with my Galaxy S6 with Android Nougat (v7)... I'll post here if app crashes again...

Me too. Have reported it to the developers. Android says I have 900 crashes in the last 1 day..
Me too. Have reported it to the developers. Android says I have 900 crashes in the last 1 day..
Got the new software update today but the crashing app problem still remains on my nexus 6p android version 7.1.2.
I have the same problem which is super annoying. Hope they will get the problem fixed whit the new version.
Login or Signup to post a comment