Start a new topic

New internal firmware

Hello All, first of all godd job with this kind of display the life is easier... I'm the owner of IM150416004.

I have  small issues with the serial.

First of all I can't upgrage hmi file.

I go through a Keyspan USB/RS232 adapter and nextion is not recognized if i want to update wtih nextion editor. Port is set and scan for several speed and connect failed message.

I have a second issue : my adapter is working properly as I can get data out from the nextion... but here is a capture of the data out


I use several button (keypad) with a crop image and use "send component id" in each release event. Why the output is 0x4d instead of 0x65??? where can I get page and button number??

Moreover I can't send command as an example page 0 0xff 0xff 0xff is not working at all, neither rest 0xff 0xff0xff

Could you help?


Can you provide your HMI and code you are working with that gives these results?

I can not think of anything in the Nextion Instruction set that would give these results other than user initiated print or printh commands - in which case it would be as intended and not an error.

Please inform of which MCU used when you submit your code and HMI

Which Keyspan USB/RS232 are you using?

Hello Patrick,
thank you for your prompt reply
===========> HMI 2.8'' NX3224T028
===========>Keyspan USA-19HS
I don't use MCU for the time being only sniffing and sending command through termite(  via Keyspan.
enclosed HMi test2.
When debugging via Nextion editor ==> 0x65
Same with termite as sniffer : 0x4d

Thanks for your help.


(425 KB)

There is nothing in your HMI that is sending our print or printh statements

This puts the onus on your Keyspan and how the Termite software is interpreting data properly.

The Keyspan USA-19HS is a software implementation of a serial driver via USB

I believe at higher than 9600 baud, more communications issues (missing bits) occurs.

This is apparent in their documentation.

Your HMI was tested and Keypad.b11 returns

0x65  0x01 0x15 0x01 0xFF 0xFF 0xFF as expected.

Keys also send out exactly as expected.

It may be possible to run at a lower baud of 9600 or lower

or a USB to TTL with Prolific chipset may be a better solution

Itead also sells a foca adapter in their store

OK, i have tried with lower speed 4800 and 9600, still same issue.

On the other hand I have tried with a Arduino nano connected to usb, and reset pin set to 0 to make the FTDI chip diectly linked to TX RX pin without interfering to atmel 328 and ... it works fine :-)
So I suspect something wrong in keyspan adapter. This is the first time. I use it dally at 115kbds with other stuff without any issue...
lets do it with nano ...
 I close as "solved"
Again thank you for support.


Login or Signup to post a comment