Start a new topic
Solved

model does not match

I have tried the various solutions for this problem and none of them have worked for me. Tried uploading a blank project, tried displaying the baud rate (it shows 9600), tried updating the baud rate to 115200, but it still shows 9600. I am using a NX3224T028_011 board (at least that is what is printed on the back), but I always get Model does not match, then Device Model NX3224T028_011R. Note the extra "R" at the end. No idea if this is significant or not. 

I am using Nextion Editor V0.40, running on PlayOnLinux under Linux Elementary, 64bit. 

I also found that every time I hit Compile I get a message saying this function is not implemented yet, but it creates the .tft file anyway. Same with Debug, which doesn't appear to do anything, and Upload, which also appears to do nothing.

I also found that the install .exe file would not work using PlayOnLinux or Wine or WineTricks. The .msi file embedded in the .exe file however does work. Maybe you could provide a download link with the .mst for us poor Linux users who can't cope with using M$ Windoze...

Thanks,

Ian


Your blank project needs to have the Setting set exactly to the Basic 2.8"

This sounds as if the Enhanced may have been selected, and/or a model was not defined.


Please use the Attach a File to upload a sample of your compiled TFT


It is unfortunate that Linux is not supported, but it is not supported.

However, there are four downloads on the download pages

1 and 2 download an exe install, 3 and 4 download a zip

The zip file does not require or use an .msi - just unpack to your folder.


sorry, but your description is a bit too vague to give a qualified suggestion.

"I have tried the various solutions" won't tell me anything about what you did and what not. Every suggestion I may give you, you may have already tried out, or maybe not ...


The Nextion Editor was designed to run under native plain WIndows OS. It may run under variouse available emulators, simulators or virtual machines on other OS, but that's not granted. If any user decide freely to do so, it is also under his responsibility how to run it ... that's neither a Nextion technical issue nor a bug of the Editor itself ...


For such help, we also have the "FreeChat" section, where you can address more people with maybe the exact knowledge you look for ...

Hi Gerry,

Thanks for your quick reply. After my "tried various solutions" statement I listed the things I've tried, as those were the solutions suggested in other posts about the same problem. My first sentence was just meant as a bit of a preamble for what follows. I included the information about Linux to let you know that I was not using a standard Windows environment in case you may have had some suggestions about reinstalling Windows drivers or what have you. It was just meant as extra information for you so you understood the environment I was using. I am aware that Wine ( which PlayOnLinux uses) is not a perfect emulator, sometimes it works, sometimes it doesn't. I know there are other Nextion users out there who have had great success using Nextion under Wine, so I was encouraged by that. 

Martin, thank you for your response too. I will try the zip file, but I'm not entirely sure what folder I should be unzipping it into. Does it go in Program Files somewhere?... Or will just any folder do, and then execute the editor from within that folder?

Thanks,

Ian

With the zip file type of install, you will unpack to a folder you designate and run the Editor from that folder.

This model does not match should not be a Windows/Linux issue but rather one of the model set within the TFT.

Setting the model within the TFT is a matter of settings, (size and series) prior to the TFT compile.

- this I can not check for you as you did not upload your sample TFT file as was requested.



Sorry Ian,

even your listed ones don't tell the things you really did.
"Tried uploading a blank project" won't tell what you really did.

A Project is your HMI file. And you surely can't upload any HMI file. You can upload a compiled TFT, but thats something different than your project ...

And for me as a technician, there are at least 3 different ways you can upload a TFT compilat ...

- upload via Editors build in RS232 upload function
- upload via displays SD-Card
- upload via external RS232 upload facility

all is different, with different do's and dont's ... so, maybe I missed the point where you talk about this? :-)

Now you can tell me, I am picky on details. Sorry, but even such a "detail" is maybe the reason why something on your side won't work ...

The more we know, the more exact and detailed you can describe what happens on your side, the more realistic that somebody can help ...

Hi Gerry and Patrick.

Thanks for you quick responses. I've solved the problem though, Nextion Editor does not work under PlayOnLinux or Wine on Linux. I know there are a number of posts around the net that says it does, but I have had no luck. After much (and I do mean much) experimenting I finally got it to install, then actually to create an HMI file, then compile appeared to not work as it gave me a "function not yet implemented " message but created the .tft file anyway, Debug gave me the same message and then did nothing, and Upload also did nothing but that's not surprising as I have a basic screen that I'm pretty sure doesn't support direct upload. I can only load a program with the SD card. 

Anyway, all that aside, I finally bit the bullet and fired up Windows 10 (which I hate doing, my PC is over 10  years old and Windows runs slower than a dog with one leg...), and as I so rarely use it it spent the next half an hour updating itself, during which time literally nothing worked. I couldn't even start task manager to see what was happening. Finally got to download and install Nextion Editor, and meanwhile Norton is going berserk so I had to run a scan which took another hour. Only then could I create a simple project with one text field on it, which I was able to successfully load onto the Nextion screen, and it worked. The problem, I eventually figured out, was that the .tft files created by Nextion under Linux were zero length. I only noticed this as I was copying then from Linux to Windows. It seems the first thing the firmware on the board does is check the model number, and finding nothing at all, gives an error message that the model number is not correct. Not a bug with Nextion Editor of course, but a bug in the interface between the Nextion Editor and Wine/Linux which, for some reason, writes a zero length file.

So the only option I have it seems is to use Windows to do my Nextion programming. Everything else (Arduino IDE and PlatformIO) runs fine on Linux.

Anyway, thanks for your patience, I'm sure I'll be back to ask many more question!

Just BTW, is it your intention to make Nextion Editor open source? I'm sure if you did versions for other platforms, (Linux and Mac) would probably appear within weeks, and cool new features would probably pop up too. Just a thought.

Thanks,

Ian


Hi Ian,


great that you have a "working" solution. All I can recommend now is, play around with your Nextion, try out things, and have fun ...

The Nextion can handle much more things than most people would expect. Away from HMI, even complex speedy arcade style standalone games are possible ... with sprites, collision detection, effects, you only need to know how to use the available ...


Due to legal reasons, it is neither possible nor planned, to make things open source. But who knows what happens tomorrow ...


Have fun


Gerry

Login or Signup to post a comment