Start a new topic

Cannot pair wifi smart switch

I just bought six Sonoff wifi switches but I can't get them to work. When I try and pair with the Sonoff I get the "incorrect password" message. I am using 12345678. Or it accepts the password and connects to the Sonoff itead wifi for a few seconds and then disconnects.


I have tried with two of the switches and get the same problem. I have looked at the itead guide and FAQs. I have raised a help ticket but am not getting a response. Can anyone help or give me advice?



6 people have this problem

Any solution for the "incorrect password" message? Best regards Kay
No. I asked itead support and they couldn't help me. They told me to ask EWeLink support which was very painful and they couldn't help me either. Pretty useless.
Hi For the first time Connecting Move the sonoff switch near the router Then try to connect them

You have a iPhone or android? With android, you do not connect directly to the itead-wifi.

If you have iPhone: the itead-wifi is only for pairing. The ewelink-app sends the name+pwd of your wifi to the sonoff device using the itead-wifi for a few seconds. When this is done, the itead-wifi is no longer used.


I purchased 4 of these switches. I have successfully paired just one switch. I am using an iPhone 6S running 10.2.1 iOS. The first switch I paired with some difficulty. I tried both the "LED blinking way" options. When selecting the first option the EWeLink app asks me to open the WiFi settings and select the WiFi network "ITEAD-******". I had to refresh my WiFi settings for an hour before the "ITEAD-******" network showed in my WiFi settings. Once it pair the device was able to finish the set up. I can't seem to pair a second switch. I've tried both "LED blinking way" options but neither work. My iPhone can not  find the "ITEAD-******" network or when I select the second "LED blinking way" option my network is found by the EWeLink app but when it moves into configuation mode it always gives me a "Pairing Failed" message. I have the switch set to pairing mode (holding the pairing button for 5s), my WiFi password is correct and I am pairing the device right next to my WiFi rounter so distance isn't an issue.

The EWeLink App says that the onboard WiFi network name is ITEAD-******" and the password is "12345678" but I can't seem to get my phone to see the switche's WiFi network. Not sure if the switches plastic housing is interfering with the broadcasting of the WiFi network.

In an attempt to enter the WiFi network manually in my WiFi settings I opened the switch's plastic housing in hopes of finding the WiFi network name. To my surprise I did find the name printed on the label (see photo). I know the default password is "12345678" however I don't know what kind of security the switch has, WEP, WPA, WPA2, etc... Even if I had this information I'm not sure if I would be able to connect.

Any additional help would be greatly appreciated in helping me make a WiFi connection to these switches. As I mentioned above I have one of these switches working but not any of the other three.

I have similar issue as well. I bought the wi-fi switch here: https://www.aliexpress.com/snapshot/0.html?orderId=501490709660730&productId=32696290639

I'm trying to pair the switch with my Android 4.4.4 smartphone but the pairing fails with "Communication process error", see the screenshot:   https://www.screencast.com/t/NWWgF6xQ

When I try to pair the device manually using "12345678" password - the switch does not accept the password, the impression is that the password is not correct. 

Can someone help with this?


1 person likes this
Viktar Miliuk - Thank you for this reply. I opened a ticket with the people at ITEAD and so far they have not been able to help. The tech rep emailed me a few times but his solution was to use a friend's Android phone to connect the switch! Can you believe that? Now you posted one day later to say the Android phone doesn't work. I will email him your post to tell him Android is having issues too.

I too am not getting the password to work. At first I wasn't able to get my phone to even see the switch's wifi network but now I can't get it to accept the password. I've tried three different iPhones (4s, 5 and 6s Plus) and none of them will accept the password. It just says unable to join the network. I do however know the password works because I activated 1 switch but the other 4 switches I have don't work right. Not sure why it won't activate any other switches.

One thing I've tested is to see if I could pair the device with my phone while logged out of my EWeLink account in the phone's app. When I attempted to do this I received a message under the switch's wifi network name (in orange) "No Internet Connection". I assume I am receiving this message because the app isn't logged into my account. When I log into my EWeLink account and try it again that "No Internet Connection" message goes away. I do however get the switch's wifi network name to show up in my wifi list but the "12345678" password isn't working.

I am also trying to pair the switch while holding my phone right next to the switch. Both my phone and the switch are right next to the wifi router and my wifi connection to my network shows a fully healthy wifi connection.

I've considered deleting my connection to my 1 switch that works but I'm afraid that I won't be able to make the connection again.

 

Hi Lacko Illustration, thank you for the update. 

As I understand, when the switch is in "pairing" mode (when the green led is blinking), it becomes a wi-fy hot-spot broadcasting its SSID like "ITEAD-******"", so, a smartphone should be able to connect to this "ITEAD-******"" wi-fy network directly using the default password "12345678". Did you tried this with the switch that you was able to pair? I mean, try to connect your smartphone with your correctly working switch directly, not via EWeLink app. I.e. when the switch in pairing mode, just try to connect to "ITEAD-******"" wi-fy network using "12345678" password. I assume you will be able to do this. If I'm right then it means that the rest your 3 switches, as well as mine one, have a defect.

Yes Viktar Miliuk. I used the switch pairing button to activate the pairing mode but it only works with one of the switches. The switch broadcasts the "ITEAD-******" network name but the password doesn't work. I'll try connecting to the switch that works to see if I can pair it again. I actually received a dual switch that I have not tried to pair yet. So far I have one switch that works. 3 switches that I can not pair and 1 dual switch that I have not tested yet. I'll keep you posted but I think you are right. We might have some defective units. Can you please re-post the link to the place you purchased your Sonoff switch. The link in your last post isn't working.

 

 I tried pairing the switch both ways and still no connection. See photo.

Im having the same issue here. The sonoff dual worked correctly, but with the standard sonoff i'm not able to connect to wifi for pairing using the 12345678 password Any updates?

I Have two devices, one was Paired ok and the other does not conect whatsoever i do... it will conect directly to the phone with the PW, but will not pair to App..


1 person likes this
Login or Signup to post a comment