Start a new topic

Can't Pair Sonoff TH16's

Apologies -- posted this in the wrong forum to begin with. Admins, please go ahead and delete the other one.


I just received two Sonoff TH16s, and can't pair either of them. I put them into pairing mode (power them up, long press on the button until the three flashes) but I can't see a WiFi network from either of them to connect my Android phone to.


I've searched for the networks on multiple Android devices (and a laptop), and I've installed a WiFi analyser app to see if it shows up on the spectrum somewhere. But neither appear on there, either.


I'd put it down as a faulty unit, but given that both TH16s are doing the same thing, it makes me wonder if I'm missing something.


I also have two Sonoff Wifi Smart Switches, and paired both of those just fine, and they're working nicely in the app.


Any advice? Thanks!


I had the same problem but solved it.

You must long press the pairing button just after you plug the mains. It can not be too fast nor too late. When you press too fast the blue LED doesn't blink at all. When you press too late the LED blinks like option two in the EWeLink mobile application (I used iPhone) and Sonoff is not transmitting any Wi-Fi. You must press a few seconds after plugging the mains and then Sonoff will blink like on first picture (in the application) and W-Fi with SSID ITEADxxxxxxx is present. Then you continue with the setup. At this stage I had problem with default password for Sonoff W-Fi (that is 12345678). It was not accepted. I restarted Sonooff and second time the password worked.

 

This device is great. I was having trouble pairing. When both sides are connected, the device does not want to pairing. When I disconnect the wires at the output side, the device was immediately paired with the application and then I connect the wires to the output side. Now everything works great.
Login or Signup to post a comment