Start a new topic
Solved

Upload failed

I'm using a NX3224T024_011 Display. After updating the Nextion editor to v0.39,

the editor updated the firmware of the display and uploaded my project. But when I want to update the project now, the upload process stopped and I get following error message on my display:


Model does not match

Device Model:

NX3224T024_011R 


What to do?


sstaub


Stefan


I am looking into this for you.  So three tasks for you to do.


1) can you post your TFT file (open Build Folder) one previous that worked and new one that doesn't

2) Open a support ticket in the upper right corner

3) Get back to me on what their solution is


If they don't have a solution, I will be seeing what I can get done.


Looking at this without your TFT files yet


It may be that you created your HMI and did not set the settings for the 2.4" Nextion.

When settings are for the 2.8" (same size), it is created for that model, - it will not upload a TFT created for one model to another model.  Settings have to be for your model.


I could verify this if I had your failed TFT file.

Hi, are there any news about this issue. In 0.40 the problem stays. Upload via SD card works.

Hi Stefan,


I am going to request this step by step.


Please create a small HMI project with one page and one Text Component

You will need to include one font for the Text Component to work

In the page PostInitialization Event please put

  cov baud,t0.txt,0

Compile this project.  Copy the project *.tft file from the bianyi Build Folder to a clean microSD

Upload the TFT file to your Nextion Device via the microSD method

This will report on the screen what the Nextion device serial baudrate is currently set at.


Confirm your in your settings that you are trying to use that baudrate with your device.




Thank you, i can upload on the forced baud rate (9600).

How to change the baud rate. Uploading the complete flash (4Mb)

needs very much time. It seems that autodetection doesn't work.

If you can connect to the Nextion device

- send the command bauds=115200

or add the command bauds=115200 to the page PostInitialization Event


This only needs to be done once (and not in every compiled HMI)


This will change the baudrate to 115200 and save it as the default power on baudrate.

From this point forward, the baudrate for that device will be 115200 until you change it.


You can test this by using the TFT you made previously to display the baud setting.

From time to time, I also have auto-connect issues

This requires me to shut down my Nextion Editor and comms and reopen to clear the comport handles.

Every couple of days is not an issue - but, on every connection, that would be an issue.

After changing the baud rate to 115200 the upload works as expected. Thank you very much.

Your welcome