Start a new topic
Solved

Installation version 0.36 freezes and unable to instal any more

 Today version 0.35 worked fine, then got message about new version 0.36 - big mistake! It begins to instal, then freezes (hang). Picture of screenshot in attachment.



And this screen stays whole day. Tried reset comp, tried delete old version then re-instal... nothing helps.


Anyone?



Problem solved. Install/repair/remove DOES NOT work, instead should be done next action: Start/All programs/Nextion editor/Uninstall - only then is possible to run new downloaded installation. For those who have the same problem, please consider instructions above. Thanks.

milan

---

It stopped work by now. Completely useless. No more editor. Unable to remove, unable to install again. Unable to start. Worthless display. I will discard this display and never use anymore. 


milan

---

So sad to hear of your difficulties installing v36.  I am enjoying v36 performance over v35.  Perhaps opening a support ticket (link above on forum) might get the assistance required.


I just wanted to address tossing out the display.  It is rather humorous to discard another product over your problems faced in Windows.  It would be equal to discarding a smart home or smart car because you Windows registry has issues, or throwing away your data center because a laptop is faulty.  Perhaps throwing the computer containing the offending registry may be most appropriate.


Should you still be considering discarding the display, may I request your display.  Let me know if it is not yet discarded and still available.


1 person likes this

Have you tried reinstalling v35?  Link to its download is here  I do remember reading other posts to solve version conflicts, have you tried those?  I am not certain what state your registry is in.  Did the v35 uninstall successfully.  Is the registry clear of v35 entries.  Are all the files for v35 removed.  These are general computer troubleshooting questions for which you have provided no insight.


Perhaps getting the v35 back to a known working state.  The interruption of the install process (because it was hanging, even when what other choice was possible) still creates an incomplete uninstallation/install process.  How far it got before it was terminated has probably left its task incomplete.  Cleaning the Windows registry of such entries may be necessary, refer to Microsoft CCleaner, or whatever Microsoft tool is currently supported and downloaded from Microsoft's site (Do not blindly trust many from the web). 


The reason for suggesting reinstalling v35 is that in upgrading, if an offending registry entry exists, it is most likely from v35 and therefore not incompatible with v35. (This assumes the entire uninstall  process of v35 was not fully completed - processes waiting for files to be closed before deletion - you interpreted that waiting period as "hanging")


Although most installations these days can install and use right away, best practices is to reboot after an installation of new software before using the software, just incase additional commands were sent to runonce to finalize installation at a point when files would be known to be closed (upon restarting).


The Link to v35 was provided by the Support Team and found in the FAQ posts.  There are many answers within the board, including as I recall, information on what it was that we residual between v34 and v35.  I have to assume your issue is similar to it.  Did you look through the other posts, or merely jump straight to here when looking for your answer?



Did you try the Manual Update as stated on the screen.  The button launches to Manual Update

http://nextion.itead.cc/download.html



Hi,
I have problems too with the version 0.36
I would like to install the version 0.35 again, but your link its for download the version 0.33 and it doesn't work with mi project builded on 0.35
I tryed to uninstall and install the version 0.36 repeated times and finally works in part. The buttons doesn't work, and the display its free of frame, theres nothing else apart from my finger touching the display...
Why the same project, without modify, uploaded with 0.35 works fine and uploaded from 0.36 doesn't work?
Thanks!
I need a solution, even the good link to download the 0.35 its a good solution.

 

Trying that link again.  v35 here  and thread where it was found was here


1 person likes this

After do a lot of tests, one of displays works fine and the other not. So I have discard the incopatibility of software...

Both are the same model, but one works with touch buttons, and in the other doesn't work the touch buttons. Why?

Its the same program, with same version compiled, all the same. One works fine, the other not.

What can I do?

Can flash it? Return to fabrication state? How?

Though usually never required - issue the touch_j command to your Nextion having touch issues.  This command will calibrate your touch sensor. 


The uploading of a tft is the flashing process.  Make sure you have a formatted Fat32 SD card 32GB or LESS, only one tft file on the card, insert into Nextion, restart Nextion.  Flashing by sd card will have less chance of corrupted rx/tx transmission compared to over TTL.  Factory contained a demo HMI that can be found in the FAQ section.


If still having issues - open "New Support Ticket" at top of this page and discuss exchange if still under warranty.


1 person likes this
Thanks, now are working fine both!