Start a new topic
Solved

NEXTION 34 COMPILING ERROR

On previous NEXTION all ok, but in 34 is impossible to compile, also a simple test with only a button and little font!!!..I receive this error:


Error:Impossibile caricare il file o l'assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' o una delle relative dipendenze. Impossibile trovare il file specificato.

Error:error:L'indice deve essere compreso nei limiti dell'elenco.

Nome parametro: index

Error:Compile failed! 2 Errors, 0 Warnings,


Tried on PC with Vista and 8.1... 


There is some help?

REgards!



The best is you post your HMI File here.


Did you choose a Display Type and Orientation?

Hi Alex..thanks for your hint!
Well, I will post post a Hmi file, but I think the problem it's no HMI dependent, because some old projects or a new one also with only one component fail to compile!
Downgraded NEXTION IDE to .33.....same problem.....downgraded to 32... is running fine!
For display type and orientation....yes, of course....tried vertical, horizontal, for 3.2 and 3.5 inch (basic display I have)...but no result!
Hoping in some more hint,
regards!

 

Carlo,


What is the full version numbers on the back of the displays? 
Such as: NX4832T035_011N or TJC4024TO32_011R

Or this is something depending on Dot.Net Version or Java or whatever.


It runs on so many other PCs so it could be the error is your windows pc.

Thanks for your ansaware

To Patrick: mine is true ITEAD, not for China market...I know story.. and error is before connecting to display..no compiling for the debugger!

To Alex: may be for this...but stranger is that in 32 all was OK! Where may I find something to try to correct java or others junks?


Tried with new 35.....ERROR when I try to compile also a clear page or with only a button!!!


Everything you are describing seems that the 3.5 NET may have become corrupted on that PC.  Possibly the Nextion IDE 32 and below may not have  implemented a particular NET instruction that was introduced in the IDE versions 33 and forward.  If a partial corruption, then 32 continues to work while 33,34 and 35 fail.  Since this started before version 35 of the IDE the System.Core is more likely to 3.5 NET.

Is it an option to uninstall and reinstall your Windows NET 3.5, though if it is a pain, it may correct the issue across the IDE versions.  If you already have many 3.5 NET programs installed, one may have tweaked 3.5 function for their purpose breaking 3.5 NET for others - such as IDE 33 and up.

Though not of my doing, I will apologize that there was no official response.

Many versions have been released since - with v0.36 solving many pre0.36 issues.


This will be marked as historic and as such solved.