Start a new topic
Solved

Resource file Error on new versions of Nextion IDE

I use newest version of Nextion IDE 0.14, 0.15, 0.16, and when I try copy *.tft bin project file to Nextion LCD a see error: "Resource file Error"

But when I use old version Nextion IDE 0.9 it copy and work fine.

jpg
(47.2 KB)

1 person has this problem

See attached TFT files

tft
tft
did you figure it out in the meantime ?
It' a shame that the Itead people let us alone here with our problems :-( :-(  :-(

 

Yep.. since v0.10, some algorithm is changed, so the tft bin file is not compatible with the new version.




Hi, I have the same problem, do you (or someone) have a link for me for version 0.9 to download? just testing, developer is getting me support alright, but i wan't to try out the 0.9 version?


Or someone knows how to update the display firmware to use the newest 0.28 IDE?


1 person likes this

Thx alot, much appreciated, russian website, nice, I googled a lot, but found zero.

 Upload your first compiled Project by Serial and not SD Card! During the upload over Serial a new Firmware will be uploaded too!


2 people like this

Ok, worked, but now another big problem:


after updating from 0.9 to 0.28 there is the touch panel upside down, so y is from 320to 0 and x is from 240 to 0. Before update there was everything ok!!


Can I go back to version 0.9???


yours

Alexander Predl

Ok solved!


touch_j command did the trick, open a "debug" session, connect to the display

enter in the command field touch_j and press link "Run all commands", calibrate the display, horizontal and vertical, your finished.

This platform don't work. I'm disappointed and I go back to standart arduino TFT with library of http://www.rinkydinkelectronics.com/index.php

@Daniel


which platform?  Version 0.9?  Version 3.5 is current.

I use Nextion editor v0.35 and lcd NX4024T032. I can't upload file.  "Resource file Error" I try with FTDI and Error agayn. What is the problem?

I used to upload the firmware by SD Card but I had the same problem... then I upload by serial port and the problem solved.
Login or Signup to post a comment